Troubleshoot “connection to KMS server failed” error

I have received a lot of complaint emails saying that they could not activate their program after folowing instructions in my videos. The issues described here are related to an error message they got as below.

The connection to my KMS server failed! Trying to connect to another one… Please wait…
Sorry! Your version is not supported.

There are two main causes of this issue.

1. The cause of client

First of all, please checkout the latest versions of my scripts here. Most people have trouble using my old ones to activate their apps. Make sure that Windows Update is enabled and your intenret connection is stable before running the batch files. To check if my KMS servers are blocked or not, please open your internet browser then try going to: http://kms8.msguides.com/. If the page is visible, it means this server is not blocked.
One other point to note is that you need to run command prompt/batch file with admin rights.

Make sure "administrator" is in the title
Make sure “administrator” is in the title

Otherwise, the connection will be denied by UAC system.

2. The cause of server

Recently I need to do some experiments in the kms7 server so I changed the default KMS port (1688) to another one. And besides, I upgraded CPU and RAM memory on the kms server.
Because the number of daily clients is too big and still increasing over time, so the server can also be stuck at times. You can check and see if the server is overloaded or not here: http://status.msguides.com.

If you would have any questions or concerns, please leave your comments. I would be glad to explain in more details. Thank you so much for all your feedback and support!

4.9/5 - (199 votes)

Similar Posts

Leave a Reply

Your email address will not be published. Required fields are marked *

267 Comments

  1. Just now 13th Sept. 22, I used the second method (1click.cmd) to activate win.10 & it WORKED!!!
    During the command prompt process, it said cannot connect to KMS server about several times and the
    cursor was blinking and command prompt was not moving, so I thought it did not work. But when I checked the settings to see the result, I saw “Windows is activated using your organization’s activation service. IT WORKED! So keep trying!!!

  2. I keep getting error 0xC004F074. The server monitor shows no cpu usage (0/24/22) and I can access the kms-project.msguides.com. I am trying to activate Windows Server 2019 data center edition (WMDGN-G9PQG-XVVXX-R3X43-63DFG).

  3. hi when i run the script i get error as Sorry ,The server is busy,and cant respond to your request.Please try again. Why so.
    Before this i tried and it worked for me.